Update Flash Player


LFA requires a newer version of Flash Player than you currently have installed.

Adobe Flash Player is free. LFA requires version 9.0.124 or newer.

Download it from Adobe now

LFA is an accessible application.

LFA works with screen readers and screen magnifiers.